다음으로 이어서 보기 좋은 문제 K8s 고급 IRSA annotation은 있는데 STS가 계속 AssumeRole을 거부 인증 이전 후, 올바른 서비스 계정을 쓰는 pod가 계속 access denied를 받습니다. K8s 고급 ALB 컨트롤러는 권한이 맞다고 하는데 동작 하나가 계속 실패 ALB 컨트롤러가 일부 리소스는 만들 만큼 동작하는데 조정 동작 하나에서 반복해 실패합니다. K8s 고급 IRSA role이 한 네임스페이스에서는 되고 다른 곳에서 실패 차트를 업그레이드한 뒤, 같은 role을 쓰는 다른 네임스페이스는 정상인데 하나만 AWS API 접근을 잃습니다. K8s 고급 EKS 워크로드는 AWS API에 닿는데 secret 조회 하나가 계속 실패 다중 클러스터 플랫폼이 secret 동기화 방식을 하나로 표준화했는데, EKS 클러스터 계열 하나만 AWS 기반 secret 조회에 실패합니다.
K8s 고급 IRSA annotation은 있는데 STS가 계속 AssumeRole을 거부 인증 이전 후, 올바른 서비스 계정을 쓰는 pod가 계속 access denied를 받습니다.
K8s 고급 IRSA role이 한 네임스페이스에서는 되고 다른 곳에서 실패 차트를 업그레이드한 뒤, 같은 role을 쓰는 다른 네임스페이스는 정상인데 하나만 AWS API 접근을 잃습니다.
K8s 고급 EKS 워크로드는 AWS API에 닿는데 secret 조회 하나가 계속 실패 다중 클러스터 플랫폼이 secret 동기화 방식을 하나로 표준화했는데, EKS 클러스터 계열 하나만 AWS 기반 secret 조회에 실패합니다.