다음으로 이어서 보기 좋은 문제 K8s 고급 Traefik TCP 경로가 스테이징에서는 되고 운영에서 실패 스테이징에서 되던 TCP ingress 구성이, 라우터가 많고 entryPoint를 재사용하는 운영에서 오라우팅됩니다. K8s 고급 ingress 이전이 hostname은 보존하고도 실패 팀이 ingress 컨트롤러를 이전한 뒤, TLS와 라우팅은 정상으로 보이는데 hostname 하나만 인증이나 리다이렉트 흐름에서 실패하기 시작합니다. K8s 고급 서비스 메시 sidecar는 제대로 주입되는데 egress가 계속 실패 성능을 위해 노드 로컬 DNS를 켠 뒤 sidecar가 제어하는 특정 egress 호출만 실패하기 시작합니다. K8s 고급 admission webhook이 올바른 인증서를 제시하는데도 계속 타임아웃 테스트 pod에서는 webhook이 정상으로 보이는데, 네트워크 정책이나 DNS를 고친 뒤에도 모든 admission 요청이 계속 실패합니다.
K8s 고급 Traefik TCP 경로가 스테이징에서는 되고 운영에서 실패 스테이징에서 되던 TCP ingress 구성이, 라우터가 많고 entryPoint를 재사용하는 운영에서 오라우팅됩니다.
K8s 고급 ingress 이전이 hostname은 보존하고도 실패 팀이 ingress 컨트롤러를 이전한 뒤, TLS와 라우팅은 정상으로 보이는데 hostname 하나만 인증이나 리다이렉트 흐름에서 실패하기 시작합니다.
K8s 고급 서비스 메시 sidecar는 제대로 주입되는데 egress가 계속 실패 성능을 위해 노드 로컬 DNS를 켠 뒤 sidecar가 제어하는 특정 egress 호출만 실패하기 시작합니다.
K8s 고급 admission webhook이 올바른 인증서를 제시하는데도 계속 타임아웃 테스트 pod에서는 webhook이 정상으로 보이는데, 네트워크 정책이나 DNS를 고친 뒤에도 모든 admission 요청이 계속 실패합니다.