다음으로 이어서 보기 좋은 문제 K8s 중급 CoreDNS rewrite 규칙이 바뀌었는데 서비스 하나가 계속 옛 suffix로 해석 CoreDNS 재작성을 갱신한 뒤에도 서비스 하나가 계속 옛 suffix를 해석합니다. K8s 중급 CoreDNS rewrite를 고쳤는데 네임스페이스 하나가 계속 오래된 이름으로 해석 CoreDNS 재작성을 고친 뒤에도 네임스페이스 하나가 계속 오래된 이름을 해석합니다. K8s 중급 CoreDNS 네거티브 캐시가 고쳐진 Service를 가림 서비스는 복구됐는데 negative DNS 결과가 아직 캐시돼 있어 호출자가 몇 분간 계속 실패합니다. K8s 중급 NodeLocal DNSCache 롤아웃은 끝났는데 네임스페이스 하나가 계속 오래된 서비스 IP로 해석 DNS 캐시를 배포한 뒤 네임스페이스 하나가 간헐적으로 옛 서비스 IP로 트래픽을 보냅니다.
K8s 중급 CoreDNS rewrite 규칙이 바뀌었는데 서비스 하나가 계속 옛 suffix로 해석 CoreDNS 재작성을 갱신한 뒤에도 서비스 하나가 계속 옛 suffix를 해석합니다.
K8s 중급 CoreDNS rewrite를 고쳤는데 네임스페이스 하나가 계속 오래된 이름으로 해석 CoreDNS 재작성을 고친 뒤에도 네임스페이스 하나가 계속 오래된 이름을 해석합니다.
K8s 중급 NodeLocal DNSCache 롤아웃은 끝났는데 네임스페이스 하나가 계속 오래된 서비스 IP로 해석 DNS 캐시를 배포한 뒤 네임스페이스 하나가 간헐적으로 옛 서비스 IP로 트래픽을 보냅니다.