다음으로 이어서 보기 좋은 문제 K8s 중급 cert-manager 갱신이 secret은 갱신했는데 게이트웨이가 계속 옛 인증서를 서빙 클래식 ingress는 잘 갱신되는데 secret 갱신 후 Gateway API 트래픽이 옛 인증서를 서빙합니다. K8s 중급 cert-manager DNS01 챌린지가 루프 강화된 runtime class를 배포한 뒤에만 발급이 깨집니다. K8s 중급 cert-manager HTTP01 챌린지가 기본 게이트웨이에서는 되고 canary에서 실패 mesh 롤아웃 후 canary ingress 경로에서만 인증서 발급이 실패합니다. K8s 중급 cert-manager DNS01 챌린지가 올바른 zone에 도달하고도 실패 provider는 TXT 레코드가 있다고 확인해 주는데 위임된 하위 zone 하나에서 와일드카드 발급이 실패합니다.
K8s 중급 cert-manager 갱신이 secret은 갱신했는데 게이트웨이가 계속 옛 인증서를 서빙 클래식 ingress는 잘 갱신되는데 secret 갱신 후 Gateway API 트래픽이 옛 인증서를 서빙합니다.
K8s 중급 cert-manager HTTP01 챌린지가 기본 게이트웨이에서는 되고 canary에서 실패 mesh 롤아웃 후 canary ingress 경로에서만 인증서 발급이 실패합니다.
K8s 중급 cert-manager DNS01 챌린지가 올바른 zone에 도달하고도 실패 provider는 TXT 레코드가 있다고 확인해 주는데 위임된 하위 zone 하나에서 와일드카드 발급이 실패합니다.