다음으로 이어서 보기 좋은 문제 K8s 중급 CoreDNS 네거티브 캐시가 고쳐진 Service를 가림 서비스는 복구됐는데 negative DNS 결과가 아직 캐시돼 있어 호출자가 몇 분간 계속 실패합니다. K8s 중급 NodeLocal DNSCache 롤아웃은 끝났는데 네임스페이스 하나가 계속 오래된 서비스 IP로 해석 DNS 캐시를 배포한 뒤 네임스페이스 하나가 간헐적으로 옛 서비스 IP로 트래픽을 보냅니다. K8s 중급 CoreDNS 롤아웃은 성공했는데 pod가 계속 오래된 서비스 IP로 해석 CoreDNS를 배포한 뒤 노드 로컬 DNS 캐시 하나 뒤의 pod만 폐기된 서비스 IP를 계속 해석합니다. K8s 중급 CoreDNS 롤아웃은 성공했는데 pod가 계속 오래된 서비스 IP로 해석 DNS를 배포한 뒤 노드 로컬 캐시 하나 뒤의 pod만 폐기된 서비스 IP를 계속 해석합니다.
K8s 중급 NodeLocal DNSCache 롤아웃은 끝났는데 네임스페이스 하나가 계속 오래된 서비스 IP로 해석 DNS 캐시를 배포한 뒤 네임스페이스 하나가 간헐적으로 옛 서비스 IP로 트래픽을 보냅니다.
K8s 중급 CoreDNS 롤아웃은 성공했는데 pod가 계속 오래된 서비스 IP로 해석 CoreDNS를 배포한 뒤 노드 로컬 DNS 캐시 하나 뒤의 pod만 폐기된 서비스 IP를 계속 해석합니다.
K8s 중급 CoreDNS 롤아웃은 성공했는데 pod가 계속 오래된 서비스 IP로 해석 DNS를 배포한 뒤 노드 로컬 캐시 하나 뒤의 pod만 폐기된 서비스 IP를 계속 해석합니다.