다음으로 이어서 보기 좋은 문제 K8s 중급 NetworkPolicy 허용 규칙이 있는데 pod 하나가 계속 타임아웃 네임스페이스 label을 갱신한 뒤에도 pod 하나가 계속 타임아웃합니다. K8s 고급 Cilium 정책이 네임스페이스를 허용하는데도 node-local DNS가 차단 노드 로컬 DNS와 host 방화벽 강화를 함께 켠 직후 노드 풀 하나의 pod가 DNS를 잃습니다. K8s 고급 Cilium FQDN 정책은 갱신된 것으로 보이는데 pod가 계속 실패 갱신된 정책이 노드에 보이는데도 egress FQDN 규칙을 좁힌 뒤 pod가 계속 차단됩니다. K8s 중급 CoreDNS 네거티브 캐시가 고쳐진 Service를 가림 서비스는 복구됐는데 negative DNS 결과가 아직 캐시돼 있어 호출자가 몇 분간 계속 실패합니다.
K8s 고급 Cilium 정책이 네임스페이스를 허용하는데도 node-local DNS가 차단 노드 로컬 DNS와 host 방화벽 강화를 함께 켠 직후 노드 풀 하나의 pod가 DNS를 잃습니다.