벤더문제 129개· 검수 문제 1개

Docker

Docker 환경에서 일어나는 장애 문제 129개를 모았습니다.

모든 문제 129개

CICD-1530registry 정리가 이미지 레이어를 지웠는데 릴리스 작업 하나가 계속 그것을 가져옴정리 후에도 삭제된 OCI 레이어가 edge 캐시 하나에서만 계속 조회됩니다.CI/CD고급12분ProCICD-1408CodeBuild 로컬 캐시가 대부분의 작업은 빠르게 하는데 권한 있는 이미지 빌드 하나가 실패하기 시작로컬 캐시 최적화를 추가한 뒤, 권한이 섞인 빌드 파이프라인만 정리나 재사용에서 실패하기 시작합니다.CI/CD고급13분ProLINUX-1366journald 한도를 올렸는데 디스크 압박이 그대로장애 중 운영자가 journald 한도를 올렸는데 노드 디스크 압박이 실질적으로 나아지지 않습니다.Linux고급13분ProLINUX-1358journald 한도를 올렸는데 디스크 압박이 지속운영자가 journald를 공격적으로 조정했는데, 다음 장애 급증 때 노드 디스크 압박이 거의 달라지지 않음을 발견합니다.Linux고급13분ProSECURITY-1328사설 registry 로그인은 성공하는데 이미지 pull이 계속 401registry UI와 API를 서로 다른 host로 분리했는데, 로그인은 잘 되면서 이미지 pull이 계속 실패합니다.Security중급13분ProCICD-1418CodeBuild 권한 단계가 멀티아키텍처 이미지를 push했는데 다음 파이프라인이 arm64를 pull하지 못함mirror registry에 multi-arch 게시가 성공한 직후 arm64 pull에서만 배포 파이프라인이 실패하기 시작합니다.CI/CD고급14분ProLINUX-1362rootless Docker host가 재부팅은 견디고 나중에 아웃바운드 연결을 잃음rootless 런타임이 재부팅은 견디는데, 데몬 자체는 활성인 채로 네트워크 생성이나 아웃바운드 트래픽만 실패합니다.Linux고급14분ProLINUX-1323rootless Docker 서비스가 재부팅 전까지만 됨노드 이미지를 갱신한 뒤, 재부팅하면 누군가 수동으로 로그인할 때까지 rootless 컨테이너 서비스가 내려가 있습니다.Linux고급14분ProLINUX-1336rootless Podman이나 Docker 서비스가 업그레이드는 견디고 재부팅 후 실패강화된 host가 rootless 컨테이너용 전용 서비스 계정을 쓰는데, 재부팅 후 누군가 로그인할 때까지 런타임이 내려가 있습니다.Linux고급14분ProLINUX-1392rootless 컨테이너 런타임이 한 host에서는 되고 다른 곳에서 실패rootless 런타임 배포가 대부분의 host에서는 성공하는데, 다른 신원 도메인에 합류한 노드 하나가 컨테이너 시작을 거부합니다.Linux고급14분ProCICD-1396릴리스 provenance 검사가 registry 하나에서만 실패서명된 아티팩트가 한 registry에서는 검증되고, 이전이나 복제 후 다른 registry에서 실패합니다.CI/CD고급14분ProCICD-1356BuildKit 캐시 import는 정상으로 보이다가 이후 모든 merge 빌드가 coldregistry 정리로 새 스캔 워크플로를 도입한 뒤, 캐시 태그는 그대로인데 CI 캐시 재사용이 조용히 사라집니다.CI/CD고급15분ProCICD-1366Buildx 멀티아키텍처 릴리스가 manifest list를 게시하는데 아키텍처 하나가 사라짐registry 정리 작업을 도입한 뒤, 아키텍처별 빌드 로그는 초록인데 multiarch 릴리스가 간헐적으로 플랫폼을 빠뜨린 채 나갑니다.CI/CD고급15분ProCICD-1376Buildx 멀티아키텍처 릴리스는 초록인데 아키텍처 태그 하나가 없음registry 정리 최적화를 도입한 뒤, 빌드 로그는 초록인데 일부 multiarch 릴리스가 플랫폼 하나 없이 나갑니다.CI/CD고급15분ProCICD-1334Compose 배포가 생성된 마이그레이션 산출물을 지움로컬 compose 워크플로가 잘 돌다가, 실시간 편집용으로 디렉터리를 마운트한 뒤 컨테이너 하나에서 생성된 마이그레이션이나 자산 파일이 사라집니다.CI/CD고급15분ProCICD-1354NGINX 뒤 registry가 인증은 받아들이고 큰 push에 실패보안 강화 변경을 전역 머지한 뒤, 로그인과 메타데이터 호출은 멀쩡한데 큰 registry push만 멈추기 시작합니다.CI/CD고급15분ProCICD-1374NGINX 뒤 사설 registry가 로그인은 제대로 되는데 큰 push가 멈춤전역 프록시 강화를 배포한 뒤 로그인과 manifest 요청은 정상인데 큰 이미지 push만 실패하기 시작합니다.CI/CD고급15분ProCICD-1344NGINX 뒤의 Docker registry가 push는 받는데 이후 대용량 업로드가 멈춤명확성을 위해 리버스 프록시 설정을 재구성한 뒤 큰 이미지 push만 업로드 도중 멈추거나 실패하기 시작합니다.CI/CD고급15분ProCICD-1336registry mirror가 CI를 빠르게 해 주다가 나중에 오래된 manifest를 반환팀이 승격 중 가변 릴리스 태그를 재사용했는데, 상류 registry에는 새 이미지가 있는데도 일부 CI 작업이 옛 digest를 검증합니다.CI/CD고급15분ProLINUX-1356rootless Docker host가 DNS는 수동으로 해석하는데 컨테이너가 실패rootless 컨테이너 서비스가 재부팅은 견디는데, 네트워크 도달성은 멀쩡한 채로 이름 해석만 실패합니다.Linux고급15분Pro