벤더문제 390개· 검수 문제 4개

Linux

Linux 환경에서 일어나는 장애 문제 390개를 모았습니다.

모든 문제 390개

SECURITY-1608PAM RADIUS realm 수정은 맞는데 bastion 하나가 계속 사용자를 거부PAM RADIUS realm을 고친 뒤에도 bastion 하나가 계속 사용자를 거부합니다.Security중급8분ProLINUX-1603sudo 강화 변경은 맞는데 자동화 사용자 하나가 계속 옛 바이너리를 실행sudo 강화 후에도 자동화 사용자 하나가 계속 엉뚱한 바이너리를 호출합니다.Linux고급9분ProNETWORK-1498WireGuard 터널에 handshake는 보이는데 subnet 하나가 끝내 응답하지 않음split egress용 정책 라우팅을 도입한 뒤 WireGuard subnet이 한 방향으로만 도달됩니다.Network중급10분ProNETWORK-1508WireGuard 터널에 handshake는 보이는데 subnet 하나가 끝내 응답하지 않음split egress용 정책 라우팅 도입 후 WireGuard subnet이 한 방향으로만 도달됩니다.Network중급10분ProNETWORK-1518WireGuard 터널은 handshake되는데 subnet 하나가 끝내 응답하지 않음split-egress 정책 라우팅 후 WireGuard subnet이 한 방향으로만 도달됩니다.Network중급10분ProNETWORK-1528WireGuard 터널은 handshake되는데 subnet 하나가 끝내 응답하지 않음split-egress 라우팅 후 WireGuard subnet이 한 방향으로만 도달됩니다.Network중급10분ProLINUX-1351systemd 타이머가 손으로는 백업을 잘 쓰고 밤에 실패백업·스냅샷 명령이 수동 테스트에서는 되고 타이머로 도는 밤에만 실패합니다.Linux중급12분ProLINUX-1376디스크 압박 경보는 journald를 가리키는데 실제 증가는 정리 작업이 스캔한 적 없는 사용자 런타임 디렉터리의 rootless 컨테이너 JSON 로그에서 옴호스트는 꽉 차가는데 예상 journal 사용량은 정상입니다 — 무제한으로 늘어나는 로그가 정리 경로 밖에 있습니다.Linux중급12분ProLINUX-1349타이머로 도는 스냅샷 작업이 수동으로는 되고 밤에 AWS 자격 증명을 놓침스냅샷이나 백업 명령이 낮에 디버깅할 때는 성공하고 밤에 타이머로 트리거될 때만 실패합니다.Linux중급12분ProLINUX-1388bastion host가 SSH 인증서를 강제하는데 host 하나가 유효한 principal을 전부 거부노트북이나 bastion이 절전에서 복귀한 뒤 그 장비에서만 유효한 SSH 인증서가 거부됩니다.Linux고급13분ProLINUX-1396journald 원격 forwarder는 계속 활성인데 버스트를 버림배포판 패키지가 분리된 뒤 로그 버스트가 몰릴 때만 원격 collector에서 로그가 누락됩니다.Linux고급13분ProLINUX-1398SSH bastion이 host 인증서는 검증하는데 점프 경로 하나가 실패키를 많이 로드한 사용자가 SSH 인증서를 요구하는 bastion 하나에 더는 접근하지 못합니다.Linux고급13분ProLINUX-1354Ubuntu 클라우드 인스턴스가 계속 옛 route를 복원실시간으로 네트워크를 고쳐 host가 복구된 듯한데, 재부팅이나 재프로비저닝 후 깨진 route로 되돌아갑니다.Linux고급13분ProLINUX-1370백업 복원은 성공하는데 권한이 어긋남백업 워크플로를 단순화한 뒤, 재해 복구 테스트에서 복원된 트리의 파일은 맞는데 ACL이나 xattr이 틀린 것이 드러납니다.Linux고급13분ProLINUX-1400저장소 mirror는 도달되는데 패키지 설치가 실패mirror 인증서를 교체한 뒤 검사 프록시 하나 뒤의 네트워크에서만 패키지 설치가 실패하기 시작합니다.Linux고급13분ProLINUX-1390패키지 mirror health check는 초록인데 unattended upgrade가 실패기업 프록시 뒤의 패키지 mirror가 도달성 확인에서는 정상인데 이후 unattended 업그레이드가 검증에 실패하기 시작합니다.Linux고급13분ProLINUX-1330패키지를 재설치해 바이너리는 복원됐는데 SELinux가 계속 실행을 거부복구 조치로 패키지를 재설치했는데, 이후 서비스 하나가 장애 전에는 되던 스크립트나 바이너리를 실행하지 못합니다.Linux중급13분ProLINUX-1317Docker bind 마운트는 맞아 보이는데 파일 권한이 계속 실패서비스를 다른 컨테이너 실행 흐름으로 옮긴 뒤에야, 그대로인 host 경로에 대한 쓰기가 실패하기 시작합니다.Linux중급14분ProLINUX-1332Fedora host가 네트워크에 붙는데 운영 트래픽을 못 받음host 이미지 갱신으로 인터페이스 명명이 바뀐 뒤, 재부팅 후 노드 하나가 예상 밖의 VLAN이나 주소 체계에 나타납니다.Linux고급14분ProLINUX-1364Fedora host는 깨끗하게 업데이트되는데 컨테이너 DNS가 실패갱신이나 재연결 이벤트 후, 기본 연결성과 일반 DNS는 멀쩡한데 일부 도메인만 실패합니다.Linux고급14분Pro