자격증문제 955개· 검수 문제 24개

CKA

CKA 준비에 도움이 되는 장애 대응 문제 955개를 모았습니다.

모든 문제 955개

K8S-1504cert-manager 갱신이 secret은 갱신했는데 게이트웨이가 계속 옛 인증서를 서빙클래식 ingress는 잘 갱신되는데 secret 갱신 후 Gateway API 트래픽이 옛 인증서를 서빙합니다.Kubernetes중급10분ProK8S-1419CNI 이전 후 host-network ingress 애드온이 트래픽을 거부하기 시작pod 자체는 ready인 채로 ingress 애드온을 새 데이터플레인으로 이전한 뒤에만 트래픽이 끊깁니다.Kubernetes중급10분ProK8S-1485CSI 복원은 잘 마운트됐는데 앱이 계속 읽기 전용 파일을 봄복원된 워크로드가 볼륨은 마운트하는데, 재사용 경로로 스토리지 쪽 복원을 한 뒤 쓰기를 하지 못합니다.Kubernetes중급10분ProK8S-1476CSI 볼륨은 마운트됐는데 앱이 쓰기를 못 함subPath를 켠 채 재사용 마운트 경로로 복원한 뒤에만 stateful 앱이 쓰기에 실패합니다.Kubernetes중급10분ProK8S-1436Grafana Agent operator가 네임스페이스 하나를 놓침label이 비동기로 주입될 때, 오퍼레이터 재시작이나 재동기화 후에야 모니터링 온보딩이 됩니다.Kubernetes중급10분ProK8S-1426Grafana Agent 배포가 네임스페이스 하나를 계속 어둡게 둠네임스페이스 label이 비동기로 주입될 때, 오퍼레이터를 재시작한 뒤에야 모니터링 온보딩이 성공합니다.Kubernetes중급10분ProK8S-1429host-network ingress 애드온은 Ready인데 새 health 엔드포인트 하나가 끝내 응답하지 않음애드온 업그레이드 후 pod와 주 리스너는 정상인데 ingress health check가 실패하기 시작합니다.Kubernetes중급10분ProK8S-1439host-network ingress 애드온은 Ready인데 새 health 포트 하나가 계속 실패애드온 업그레이드 후 pod와 주 리스너는 정상인데 ingress health check가 실패하기 시작합니다.Kubernetes중급10분ProK8S-1478Istio AuthorizationPolicy가 JWT 트래픽은 허용하면서 브라우저 클라이언트를 계속 막음curl에서 토큰을 실은 직접 요청은 성공하는데 브라우저는 그 서비스에서 실패합니다.Kubernetes중급10분ProK8S-1469Istio WebSocket 경로가 TCP 세션은 유지하면서 인증을 잃음라우팅을 정리한 뒤 일반 API 호출은 통과하고 WebSocket 업그레이드가 인증을 잃습니다.Kubernetes중급10분ProK8S-1464Ubuntu 노드 풀 하나에서만 CoreDNS 루프worker 이미지 계열 하나가 더 새로운 Ubuntu 릴리스로 옮긴 뒤에만 CoreDNS loop 경고가 시작됩니다.Kubernetes중급10분ProK8S-1400정리 작업이 옛 ReplicaSet을 지운 뒤 롤백이 불가능해짐이력 정리 최적화를 도입한 뒤 평소의 GitOps나 배포 UI 경로로 롤백하지 못하게 됩니다.Kubernetes중급10분ProK8S-1444cert-manager DNS01 챌린지가 루프강화된 runtime class를 배포한 뒤에만 발급이 깨집니다.Kubernetes중급11분ProK8S-1462cert-manager DNS01 챌린지가 올바른 zone에 도달하고도 실패provider는 TXT 레코드가 있다고 확인해 주는데 위임된 하위 zone 하나에서 와일드카드 발급이 실패합니다.Kubernetes중급11분ProK8S-1453cert-manager HTTP01 챌린지가 기본 게이트웨이에서는 되고 canary에서 실패mesh 롤아웃 후 canary ingress 경로에서만 인증서 발급이 실패합니다.Kubernetes중급11분ProK8S-1456Gatekeeper mutation이 기본 스토리지 클래스를 붙였는데 스케줄러가 워크로드를 거부mutation 정책이 storage class 기본값을 넣기 시작한 뒤, 잘 스케줄되던 워크로드가 pending에 머무릅니다.Kubernetes중급11분ProK8S-1416Grafana Agent DaemonSet은 정상인데 노드 하나가 끝내 로그를 전달하지 않음클러스터 로깅이 대부분의 노드에서는 되는데 새로 패치한 worker 풀에서만 로그가 누락됩니다.Kubernetes중급11분ProK8S-1406Grafana Agent operator 롤아웃이 네임스페이스 하나를 모니터링하지 않음모니터링용으로 네임스페이스를 온보딩했는데 이후 오퍼레이터 재시작이나 전체 재동기화 전까지 보이지 않습니다.Kubernetes중급11분ProK8S-1396Grafana Agent Operator 파이프라인이 pod는 계속 수집하는데 테넌트 하나가 트레이스를 잃음새 테넌트 네임스페이스를 만들자 메트릭은 나타나는데 트레이스는 그 네임스페이스에서 끝내 흐르지 않습니다.Kubernetes중급11분ProK8S-1390PodDisruptionBudget은 지켜지는데 유지보수 drain이 끝나지 않음서류상 PDB가 축출을 허용하는데도 일상적인 노드 점검 drain이 멈춥니다.Kubernetes중급11분Pro