자격증문제 955개· 검수 문제 24개

CKA

CKA 준비에 도움이 되는 장애 대응 문제 955개를 모았습니다.

모든 문제 955개

K8S-1606CoreDNS rewrite 수정이 반영됐는데 네임스페이스 하나가 계속 옛 이름으로 해석CoreDNS 재작성을 고친 뒤에도 네임스페이스 하나가 계속 옛 이름을 해석합니다.Kubernetes중급8분ProK8S-1586CoreDNS rewrite 수정이 반영됐는데 네임스페이스 하나가 계속 오래된 이름으로 해석CoreDNS 재작성을 고친 뒤에도 네임스페이스 하나가 계속 오래된 이름을 해석합니다.Kubernetes중급8분ProK8S-1596CoreDNS rewrite를 고쳤는데 네임스페이스 하나가 계속 오래된 이름으로 해석CoreDNS 재작성을 고친 뒤에도 네임스페이스 하나가 계속 오래된 이름을 해석합니다.Kubernetes중급8분ProK8S-1574signerName 갱신이 반영됐는데 인증서 요청 하나가 계속 대기signerName을 표준화한 뒤에도 인증서 요청 하나가 pending에 머무릅니다.Kubernetes중급8분ProK8S-1598webhook 설정을 갱신했는데 API 서버 하나가 계속 새 타임아웃을 무시설정을 갱신한 뒤에도 API 서버 하나가 새 webhook 타임아웃을 계속 무시합니다.Kubernetes중급8분ProK8S-1608webhook 타임아웃 갱신이 반영됐는데 API 서버 하나가 계속 대기webhook 타임아웃을 갱신한 뒤에도 API 서버 하나가 계속 너무 오래 기다립니다.Kubernetes중급8분ProK8S-1588webhook 타임아웃을 낮췄는데 API 서버 하나가 계속 대기webhook 타임아웃을 줄인 뒤에도 API 서버 하나가 계속 너무 오래 기다립니다.Kubernetes중급8분ProK8S-1483CoreDNS autopath 최적화로 대부분의 조회가 빨라졌는데 네임스페이스 하나가 루프클러스터 전역으로 autopath 최적화를 켠 뒤 이전된 네임스페이스에서 간헐적 DNS 루프가 나타납니다.Kubernetes중급9분ProK8S-1526CoreDNS 갱신이 롤아웃됐는데 네임스페이스 하나가 계속 오래된 endpoint로 해석CoreDNS를 갱신한 뒤 네임스페이스 하나만 오래된 endpoint를 봅니다.Kubernetes중급9분ProK8S-1536CoreDNS 갱신이 롤아웃됐는데 네임스페이스 하나가 계속 오래된 endpoint로 해석CoreDNS를 갱신한 뒤 네임스페이스 하나만 오래된 endpoint를 봅니다.Kubernetes중급9분ProK8S-1474CoreDNS 네거티브 캐시가 고쳐진 Service를 가림서비스는 복구됐는데 negative DNS 결과가 아직 캐시돼 있어 호출자가 몇 분간 계속 실패합니다.Kubernetes중급9분ProK8S-1496CoreDNS 롤아웃은 성공했는데 pod가 계속 오래된 서비스 IP로 해석CoreDNS를 배포한 뒤 노드 로컬 DNS 캐시 하나 뒤의 pod만 폐기된 서비스 IP를 계속 해석합니다.Kubernetes중급9분ProK8S-1506CoreDNS 롤아웃은 성공했는데 pod가 계속 오래된 서비스 IP로 해석DNS를 배포한 뒤 노드 로컬 캐시 하나 뒤의 pod만 폐기된 서비스 IP를 계속 해석합니다.Kubernetes중급9분ProK8S-1516CoreDNS 변경을 적용했는데 네임스페이스 하나가 계속 오래된 IP로 해석CoreDNS를 갱신한 뒤 노드 로컬 캐시 하나 뒤의 네임스페이스만 계속 오래된 서비스 IP를 봅니다.Kubernetes중급9분ProK8S-1578namespaceSelector 갱신이 반영됐는데 webhook 하나가 계속 네임스페이스를 무시selector label 이름을 바꾼 뒤 webhook 하나가 네임스페이스를 무시합니다.Kubernetes중급9분ProK8S-1556NodeLocal DNSCache 롤아웃은 끝났는데 네임스페이스 하나가 계속 오래된 서비스 IP로 해석DNS 캐시를 배포한 뒤 네임스페이스 하나가 간헐적으로 옛 서비스 IP로 트래픽을 보냅니다.Kubernetes중급9분ProK8S-1566NodeLocal DNSCache 재시작은 성공했는데 네임스페이스 하나가 계속 NXDOMAINsearch suffix를 바꾼 뒤에만 네임스페이스 하나가 NXDOMAIN을 봅니다.Kubernetes중급9분ProK8S-1568admission webhook manifest를 갱신했는데 네임스페이스 하나가 계속 그것을 무시manifest를 강화한 뒤에도 네임스페이스 하나가 계속 webhook을 무시합니다.Kubernetes중급10분ProK8S-1558admission webhook 인증서가 교체됐는데 API 서버 하나가 계속 x509 오류를 보고인증서 교체 후 API 서버 하나만 x509 webhook 오류를 보고합니다.Kubernetes중급10분ProK8S-1494cert-manager 갱신이 secret은 갱신했는데 ingress가 계속 옛 인증서를 서빙클래식 Ingress에서는 잘 되는 secret 갱신 후에도 Gateway API 트래픽이 계속 옛 인증서를 서빙합니다.Kubernetes중급10분Pro