벤더문제 586개· 검수 문제 4개

Kubernetes

Kubernetes 환경에서 일어나는 장애 문제 586개를 모았습니다.

모든 문제 586개

K8S-1499Gateway API canary 경로는 맞아 보이는데 트래픽 100%가 계속 stable로 감컨트롤러 리비전 하나에서 Ingress를 Gateway API로 옮긴 뒤 canary 가중치가 끝내 적용되지 않습니다.Kubernetes고급11분ProK8S-1509Gateway API canary 경로는 붙었는데 트래픽이 전부 stable로 감Gateway API 이전 후 컨트롤러 리비전 하나에서 canary 가중치가 끝내 적용되지 않습니다.Kubernetes고급11분ProK8S-1553Gateway API listener가 바뀌었는데 edge pod 하나가 계속 옛 경로를 서빙게이트웨이 fleet의 나머지는 맞는데 edge pod 하나에서 route 변경이 실패합니다.Kubernetes고급11분ProK8S-1513Gateway API 경로는 붙었는데 계속 옛 백엔드를 서빙Gateway API를 바꿨는데 게이트웨이 worker 하나에서 백엔드 전환이 끝내 반영되지 않습니다.Kubernetes고급11분ProK8S-1523Gateway API 경로는 붙었는데 워커 하나가 계속 옛 백엔드를 서빙route를 바꿨는데 게이트웨이 worker 하나에서 백엔드 전환이 끝내 반영되지 않습니다.Kubernetes고급11분ProCICD-1536GitOps 이미지 업데이트는 반영됐는데 롤백이 실패GitOps 워크플로에서 registry digest alias를 정리한 뒤에만 롤백이 실패합니다.CI/CD고급11분ProCICD-1546GitOps 이미지 업데이트는 반영됐는데 롤백이 실패GitOps 흐름에서 digest alias를 정리한 뒤에만 롤백이 실패합니다.CI/CD고급11분ProSECURITY-1405htpasswd secret을 갱신했는데 ingress가 계속 옛 비밀번호를 받아들임Kubernetes에는 자격 증명 교체가 반영된 것으로 보이는데, pod를 재시작하기 전까지 옛 비밀번호가 계속 통합니다.Security중급11분ProK8S-1571Hubble relay 갱신이 롤아웃됐는데 flow 스트림 하나가 계속 옛 identity를 태깅Cilium을 배포한 뒤에도 Hubble relay 하나가 계속 옛 신원을 태깅합니다.Kubernetes고급11분ProK8S-1490ingress-nginx admission 패치는 성공했는데 websocket 업그레이드가 계속 실패ingress annotation을 중앙화한 뒤 canary 사용자에게만 WebSocket 업그레이드가 실패합니다.Kubernetes고급11분ProK8S-1559IRSA 이전은 끝났는데 DaemonSet 하나가 계속 클라우드 접근을 잃음IRSA 이전 후 더 오래된 노드에서만 DaemonSet이 AWS 접근을 잃습니다.Kubernetes고급11분ProK8S-1580Istio subset 갱신이 배포됐는데 sidecar 하나가 계속 옛 목적지를 사용롤아웃 후에도 sidecar 하나가 계속 옛 목적지 subset을 씁니다.Kubernetes고급11분ProK8S-1590mesh egress 정책을 갱신했는데 sidecar 하나가 계속 옛 host를 허용mesh egress 정책을 갱신한 뒤에도 sidecar 하나가 계속 옛 host를 허용합니다.Kubernetes고급11분ProSECURITY-1385Prometheus exporter secret을 교체했는데 알림이 계속 옛 자격 증명을 사용exporter 자격 증명을 교체했는데 sidecar가 생성한 설정 파일에 의존하는 pod에서만 메트릭이 갑자기 실패합니다.Security중급11분ProK8S-1573ReferenceGrant를 적용했는데 네임스페이스 간 경로 하나가 계속 실패ReferenceGrant를 배포한 뒤 네임스페이스 간 route 하나가 실패합니다.Kubernetes고급11분ProK8S-1563TLSRoute는 깨끗하게 붙었는데 게이트웨이 pod 하나가 계속 옛 백엔드를 서빙TLSRoute를 바꾼 뒤 게이트웨이 pod 하나가 옛 백엔드를 서빙합니다.Kubernetes고급11분ProK8S-1503API priority and fairness 갱신이 반영됐는데 kubelet heartbeat가 계속 굶주림APF를 조정한 뒤 새로 오토스케일된 노드에서만 노드 heartbeat가 열화됩니다.Kubernetes고급12분ProK8S-1481Cilium FQDN 정책은 갱신된 것으로 보이는데 pod가 계속 실패갱신된 정책이 노드에 보이는데도 egress FQDN 규칙을 좁힌 뒤 pod가 계속 차단됩니다.Kubernetes고급12분ProK8S-1561Cilium kube-proxy 대체 롤아웃이 끝났는데 노드 하나가 계속 옛 백엔드로 트래픽을 보냄kube-proxy 대체를 배포한 뒤에도 노드 하나가 계속 옛 백엔드로 요청을 보냅니다.Kubernetes고급12분ProK8S-1521Cilium 노드 업그레이드는 끝났는데 서비스 경로 하나가 계속 드롭Cilium에서 변동이 큰 서비스 롤아웃 후 노드 하나에서만 트래픽이 끊깁니다.Kubernetes고급12분Pro