NGINX
NGINX 환경에서 일어나는 장애 문제 274개를 모았습니다.
먼저 읽을 가이드
추천 문제
모든 문제 274개
SECURITY-1487SAML assertion은 검증되는데 브라우저 로그인이 계속 실패콜백 hostname을 이전한 뒤 SAML 로그인이 테스트 도구에서는 되고 브라우저에서 실패합니다.Security중급10분ProSECURITY-1496SAML 메타데이터 갱신은 성공했는데 SP 시작 로그인이 계속 루프IdP 메타데이터와 서명 인증서를 갱신한 뒤 realm 하나에서만 SP 시작 SAML 로그인이 루프합니다.Security중급10분ProSECURITY-1506SAML 메타데이터 갱신은 성공했는데 SP 시작 로그인이 계속 루프메타데이터를 갱신한 뒤 realm 하나에서만 SP 시작 SAML 로그인이 루프합니다.Security중급10분ProSECURITY-1516SAML 메타데이터 갱신은 성공했는데 SP 시작 로그인이 계속 루프메타데이터를 갱신한 뒤 realm 하나에서만 SP 시작 SAML 로그인이 루프합니다.Security중급10분ProSECURITY-1476SAML 응답은 검증되는데 브라우저에서만 실패콜백 도메인의 쿠키 기본값이 바뀐 뒤에만 SAML 로그인이 테스트 도구에서는 되고 브라우저에서 실패합니다.Security중급10분ProNETWORK-1398로드밸런서 모니터는 정상이라는데 클라이언트 POST 요청이 실패새 검사 프로파일을 켠 뒤에만 백엔드는 초록인 채로 일부 클라이언트 요청이 실패하기 시작합니다.Network중급10분ProNETWORK-1461체인 연결된 proxy protocol 구성이 엉뚱한 클라이언트 IP를 기록앱 앞에 두 번째 프록시 계층을 넣은 뒤 지역 ACL과 감사 로그가 깨집니다.Network중급10분ProNETWORK-1471프록시 체인이 HTTP에서는 클라이언트 IP를 보존하고 gRPC 감사 추적을 깨뜨림프록시 리팩터 후 클라이언트 IP 감사가 REST에는 되고 gRPC에서만 실패합니다.Network중급10분ProNETWORK-1388하드웨어 로드밸런서 health check는 통과하는데 실제 트래픽이 실패route 리팩터로 host 기반 매칭을 도입했는데 로드밸런서는 계속 백엔드를 정상으로 보고합니다.Network중급10분ProCICD-1567Helm provenance 검사가 origin에서는 통과하고 프록시 하나에서 실패OCI 차트로 이전한 뒤 프록시 계층 하나를 거칠 때만 차트 검증이 실패합니다.CI/CD고급11분ProCICD-1498Helm 차트 릴리스는 정상 서명되는데 provenance 검증이 계속 실패명명 정규화를 바꾼 뒤 edge 계층 하나를 거치는 다운로드에서만 차트 검증이 실패합니다.CI/CD고급11분ProNETWORK-1384NGINX stream 프록시가 TLS는 받아들이는데 백엔드 인증이 깨짐TLS passthrough 프록시를 강화한 뒤 백엔드 하나가 예상 밖의 출발지 신원을 근거로 클라이언트를 거부합니다.Network중급11분ProCICD-1505OCI Helm 승격은 끝났는데 provenance 검증이 실패승격이 성공한 뒤 edge 캐시 하나 뒤에서만 Helm OCI provenance 검사가 실패합니다.CI/CD고급11분ProNETWORK-1444proxy protocol health check는 통과하고 실제 트래픽이 실패Proxy Protocol 기능을 켠 뒤 로드밸런서 확인은 초록인데 운영 요청이 실패합니다.Network중급11분ProSECURITY-1455SAML 응답은 검증되는데 ACS 경로 하나가 계속 거부SAML 로그인이 한 경로에서는 되고, TLS 종단 방식이 달라진 프록시 뒤에서만 실패합니다.Security중급11분ProNETWORK-1394TCP 스트림 프록시는 계속 트래픽을 넘기는데 클라이언트 IP 허용목록이 실패하위 호환용 변경이 레거시 소비자 하나에는 도움이 되고, 다른 상류의 출발지 IP 기반 인증을 예상 밖으로 깨뜨립니다.Network중급11분ProSECURITY-1364auth_request 체인이 브라우저 UI는 보호하는데 API 경로 하나가 정책을 우회리버스 프록시가 인증을 중앙화한 뒤 API 클라이언트만 기대한 정책 검사를 피하는 경로를 찾습니다.Security중급12분ProK8S-1368cert-manager HTTP01 챌린지 실패전역 ingress annotation을 정리한 뒤 HTTP01 검증에서만 새 인증서 발급이 멈춥니다.Kubernetes중급12분ProK8S-1378cert-manager HTTP01 챌린지 실패전역 ingress annotation을 정리한 뒤 HTTP01 인증서 갱신만 실패하기 시작합니다.Kubernetes중급12분ProNETWORK-1378Cloudflare Access가 주 앱에는 되는데 내부 관리자 경로가 신원을 잃음보호된 애플리케이션이 주 route에서는 되는데, origin 재작성을 정리한 뒤 관리자 경로 하나가 갑자기 미인증처럼 동작합니다.Network중급12분Pro