벤더문제 274개· 검수 문제 7개

NGINX

NGINX 환경에서 일어나는 장애 문제 274개를 모았습니다.

모든 문제 274개

SECURITY-1354NGINX auth_request 정책이 브라우저 UI는 보호하는데 API route 하나가 그것을 우회리버스 프록시가 인증을 중앙화한 뒤, 보안 검토에서 API 경로 하나가 예상 밖의 메서드 분기로 도달 가능함이 드러납니다.Security중급12분ProNETWORK-1416경로 기반 인증 게이트웨이가 관리자 UI를 보호하는데 인코딩된 traversal 하나가 계속 도달edge에서 정규화를 리팩터한 뒤 인코딩된 관리자 경로 변형이 기대한 인증 게이트웨이를 우회합니다.Network중급12분ProNETWORK-1375로그 수집용 NGINX location이 일반 요청은 처리하고 큰 클라이언트 POST가 실패프록시 설정을 모듈화한 뒤 location 하나에서만 큰 수집 요청이 실패하기 시작합니다.Network중급12분ProNETWORK-1370리버스 프록시 real-IP 수정이 앱에는 통하는데 자동 차단이 계속 프록시를 때림real-IP 처리를 고친 뒤에도 자동 차단이나 rate limit이 남용 클라이언트 대신 프록시를 계속 대상으로 합니다.Network중급12분ProNETWORK-1406리버스 프록시가 일반 경로는 인증하고 관리자 엔드포인트 하나를 흘림테스트에서는 관리자 경로가 보호되는데, 운영에서 같은 프록시로 인코딩된 변형이 그것에 도달합니다.Network중급12분ProNETWORK-1426인증 게이트웨이가 경로를 보호하는데 인코딩된 traversal이 계속 관리자 엔드포인트에 도달정규화를 리팩터한 뒤 인코딩된 관리자 route 변형이 인증 게이트웨이를 우회합니다.Network중급12분ProNETWORK-1436인증 게이트웨이가 관리자 경로를 보호하는데 인코딩된 traversal이 계속 도달정규화를 리팩터한 뒤 인코딩된 관리자 route 변형이 인증 게이트웨이를 우회합니다.Network중급12분ProNETWORK-1446인증 게이트웨이가 관리자 경로를 보호하는데 인코딩된 traversal이 계속 도달정규화를 리팩터한 뒤 인코딩된 관리자 URL이 기대한 인증 게이트웨이를 우회합니다.Network중급12분ProK8S-1348cert-manager Certificate가 Pending에 머무름클러스터 전역 ingress annotation을 정리한 뒤 새 HTTP01 챌린지에서만 인증서 발급이 실패합니다.Kubernetes중급13분ProNETWORK-1368Cloudflare Access 앱 인증은 정상인데 관리자 경로 하나가 계속 실패Access 뒤의 프록시 앱이 대부분의 페이지에서는 되는데, 프록시를 정리한 뒤 관리자 경로 하나가 unauthorized를 반환하기 시작합니다.Network중급13분ProSECURITY-1344NGINX auth_request 체인이 UI는 보호하는데 API 경로 하나가 계속 정책을 우회리버스 프록시가 인증을 중앙화한 뒤, API 클라이언트나 브라우저 preflight 흐름만 기대한 정책 검사 없이 경로 하나에 도달합니다.Security중급13분ProSECURITY-1333NGINX auth_request 체인이 브라우저에는 되고 API 클라이언트에 실패리버스 프록시에 중앙 인증을 추가한 뒤, 같은 edge 뒤에서 API 소비자만 세밀한 인가를 잃습니다.Security중급13분ProNETWORK-1360NGINX 뒤의 OpenSearch 클러스터가 질의는 서빙하고 대량 쓰기가 타임아웃명확성을 위해 리버스 프록시를 재구성한 뒤, 검색은 멀쩡한데 부하가 걸리면 대량 수집만 타임아웃하기 시작합니다.Network중급13분ProNETWORK-1352NGINX 리버스 프록시가 앱에는 클라이언트 IP를 보존하는데 fail2ban이 계속 프록시를 차단프록시 real-IP 수정을 적용했는데도 자동 차단이나 rate limit이 문제 클라이언트가 아니라 리버스 프록시를 계속 때립니다.Network중급13분ProNETWORK-1350OpenSearch 앞의 리버스 프록시는 초록인데 대량 수집이 타임아웃route를 명확히 하려고 OpenSearch 프록시를 재구성한 뒤, 부하가 걸리면 대량 수집만 타임아웃하기 시작합니다.Network중급14분ProSECURITY-1306SAML 로그아웃이 주 도메인에서는 되고 콜백 경로에서 루프리버스 프록시가 같은 앱을 잘 서빙하다가, 경로 하나에서 로그아웃이나 ACS 검증이 루프하기 시작합니다.Security중급14분ProLINUX-1450프록시 TLS 체인이 openssl 확인에서는 맞아 보이는데 앱 하나가 계속 실패대화형 테스트는 괜찮아 보이는데 체인을 갱신한 뒤 장수 클라이언트 하나가 계속 검증에 실패합니다.Linux고급14분ProLINUX-1285Nginx는 새 인증서를 서빙하는데 OCSP stapling이 계속 실패TLS 갱신은 끝난 것으로 보이는데 일부 클라이언트나 모니터가 계속 stapling 실패를 보고합니다.Linux중급15분ProLINUX-1289websocket 백엔드가 사무실 하나에서만 끊김실시간 대시보드가 대체로 잘 되는데, 특정 회사 네트워크나 프록시 경로 뒤의 사용자에게만 반복해서 끊깁니다.Linux중급15분ProLINUX-1280리버스 프록시가 websocket 클라이언트 하나만 깨뜨림일반 웹 트래픽은 물론 다른 수다스러운 websocket 클라이언트도 멀쩡한데 websocket 기반 UI나 클라이언트 하나만 반복해서 끊깁니다.Linux중급15분Pro