NGINX
NGINX 환경에서 일어나는 장애 문제 274개를 모았습니다.
먼저 읽을 가이드
추천 문제
모든 문제 274개
K8S-1603Gateway listener 변경은 맞는데 pod 하나가 계속 옛 경로로 라우팅listener를 바꾼 뒤에도 게이트웨이 pod 하나가 계속 옛 경로로 라우팅합니다.Kubernetes고급10분ProCICD-1587Helm provenance 작업이 origin에서는 통과하고 프록시 하나에서 실패차트를 다시 게시한 뒤 프록시 경로 하나가 Helm provenance 검사에 실패합니다.CI/CD고급10분ProNETWORK-1561NGINX ingress가 새 upstream은 유지하는데 사이트 하나가 계속 옛 클라이언트 IP를 보고ingress와 real_ip를 정리한 뒤 사이트 하나가 엉뚱한 클라이언트 IP를 기록합니다.Network고급10분ProNETWORK-1571NGINX map 갱신은 맞는데 hostname 하나가 계속 옛 경로로 라우팅map을 갱신한 뒤에도 hostname 하나가 계속 옛 upstream으로 라우팅합니다.Network고급10분ProNETWORK-1581NGINX upstream keepalive 수정이 반영됐는데 사이트 하나가 계속 옛 백엔드와 통신NGINX keepalive를 고친 뒤에도 사이트 하나가 계속 옛 백엔드와 통신합니다.Network고급10분ProSECURITY-1495CrowdSec bouncer가 새 결정 목록을 읽었는데 리버스 프록시 하나가 계속 정상 클라이언트를 차단리버스 프록시 체인을 리팩터한 뒤 CrowdSec 결정을 정리했는데도 정상 클라이언트가 계속 차단됩니다.Security고급11분ProSECURITY-1505CrowdSec 결정 목록을 갱신했는데 정상 클라이언트가 계속 차단리버스 프록시 체인을 리팩터한 뒤 결정을 정리했는데도 정상 클라이언트가 계속 차단됩니다.Security고급11분ProSECURITY-1515CrowdSec 결정 목록을 갱신했는데 정상 클라이언트가 계속 차단리버스 프록시 체인을 리팩터한 뒤 결정을 정리했는데도 정상 클라이언트가 계속 차단됩니다.Security고급11분ProK8S-1499Gateway API canary 경로는 맞아 보이는데 트래픽 100%가 계속 stable로 감컨트롤러 리비전 하나에서 Ingress를 Gateway API로 옮긴 뒤 canary 가중치가 끝내 적용되지 않습니다.Kubernetes고급11분ProK8S-1509Gateway API canary 경로는 붙었는데 트래픽이 전부 stable로 감Gateway API 이전 후 컨트롤러 리비전 하나에서 canary 가중치가 끝내 적용되지 않습니다.Kubernetes고급11분ProK8S-1553Gateway API listener가 바뀌었는데 edge pod 하나가 계속 옛 경로를 서빙게이트웨이 fleet의 나머지는 맞는데 edge pod 하나에서 route 변경이 실패합니다.Kubernetes고급11분ProK8S-1513Gateway API 경로는 붙었는데 계속 옛 백엔드를 서빙Gateway API를 바꿨는데 게이트웨이 worker 하나에서 백엔드 전환이 끝내 반영되지 않습니다.Kubernetes고급11분ProK8S-1523Gateway API 경로는 붙었는데 워커 하나가 계속 옛 백엔드를 서빙route를 바꿨는데 게이트웨이 worker 하나에서 백엔드 전환이 끝내 반영되지 않습니다.Kubernetes고급11분ProSECURITY-1382Grafana auth proxy 설정은 되는데 관리자 권한이 사라짐프록시 업그레이드 후 Grafana 로그인은 되는데 role과 팀 할당이 조용히 퇴행합니다.Security중급11분ProK8S-1490ingress-nginx admission 패치는 성공했는데 websocket 업그레이드가 계속 실패ingress annotation을 중앙화한 뒤 canary 사용자에게만 WebSocket 업그레이드가 실패합니다.Kubernetes고급11분ProNETWORK-1495NGINX ingress 프록시는 HTTP/2를 제대로 서빙하는데 백엔드 하나가 계속 평문 HTTP를 봄플랫폼의 나머지가 HTTPS upstream으로 옮긴 뒤에도 이전된 백엔드가 경로 하나에서 계속 HTTP를 받습니다.Network고급11분ProNETWORK-1505NGINX upstream 이전으로 TLS를 켰는데 백엔드 하나가 계속 HTTP를 봄플랫폼 나머지가 HTTPS upstream으로 이동한 뒤에도 이전된 백엔드가 경로 하나에서 계속 HTTP를 받습니다.Network고급11분ProNETWORK-1551NGINX 게이트웨이를 reload했는데 location 하나가 계속 옛 upstream을 사용게이트웨이를 reload한 뒤에도 route 하나가 계속 옛 upstream을 때립니다.Network고급11분ProCICD-1544OCI mirror가 새 이미지를 서빙하는데 서명 검증이 계속 실패edge 캐싱을 켠 뒤 mirror 계층 하나에서만 서명 검증이 실패합니다.CI/CD고급11분ProK8S-1573ReferenceGrant를 적용했는데 네임스페이스 간 경로 하나가 계속 실패ReferenceGrant를 배포한 뒤 네임스페이스 간 route 하나가 실패합니다.Kubernetes고급11분Pro